Yahoo! ID連携 iOS用SDKアップデートのお願い

いつもYahoo! JAPANをご利用いただき誠にありがとうございます。

iOSアプリにてご利用いただいているYahoo! ID連携 iOS用SDKアップデートのお願いです。

■依頼内容
「YConnect iOS SDK ver.1.0.0」を利用し続けた場合、
今後通信ができなくなる可能性があることが判明いたしました。
つきましては現在ご利用いただいているバージョンをご確認いただき、
最新版(ver.1.0.1)へのアップデートをお願いいたします。

以下URLよりダウンロードをお願いいたします。
https://developer.yahoo.co.jp/yconnect/v1/client_app/ios/
■原因
「YConnect iOS SDK ver.1.0.0」では一部ヘッダーの実装においてRFCに準拠していない部分がありました。
これにより今後予定しているセキュリティ対策(ヘッダチェックの厳格化)において通信ができなくなる可能性があります。

■対応期限
9月末日
期限までの対応が難しい場合は、8/18(金)までにお知らせください。

今後ともYahoo! JAPANをよろしくお願いいたします。

アプリケーションの管理

開発のヒント