更新履歴 2018年06月07日

【Yahoo!ショッピング】【重要】API利用について「TLS1.0」「TLS1.1」無効化に関する重要なお知らせ


いつもYahoo!デベロッパーネットワークをご利用いただきありがとうございます。

Yahoo! JAPANでは、より安全に弊社ウェブサービスをご利用いただくために、
2018年6月1日以降、インターネット通信暗号化方式「TLS1.0」および「TLS1.1」の
サポートを順次終了いたします。

サポート終了後は、「TLS1.2」に対応していない古いブラウザやパソコン、
スマートフォン、タブレット、ゲーム機などからYahoo! JAPANが提供する
全ウェブサービス(アプリ、Web APIを含む)はご利用いただけなくなります。

また、Yahoo!ショッピングWeb APIも「TLS1.2」に対応している必要があります。
2018年9月末(予定)以降、「TLS1.2」に対応していない環境からWeb APIを利用する場合、
「TLS1.0」「TLS1.1」は接続が確立できなくなります。

▽Yahoo! JAPANセキュリティセンター
https://security.yahoo.co.jp/news/tls12.html
※対応方法の詳細はこちらをご確認ください。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
■スケジュール
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
Yahoo!ショッピング運営に関する「TLS1.2」移行スケジュールは以下の通りです。

▽ストアクリエイターPRO、Yahoo!ショッピング運営ツール
・移行:2018年9月末 予定

▽Yahoo!ショッピングWeb API
・テスト環境公開:2018年6月30日(土)予定
・移行:2018年9月末 予定

※確定次第追ってお知らせいたします。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
■影響範囲
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
「TLS1.2」未対応の場合、以下の影響が生じます。

▽パソコン、スマートフォン利用者
 2018年6月1日以降、Yahoo! JAPANが提供するWEBサービスが順次利用できなくなります。

※ストアクリエイターPRO、Yahoo!ショッピング運営ツールは、
 2018年9月末(予定)より利用できなくなります。

▽Yahoo!ショッピングWeb API利用者
 2018年9月末(予定)より、接続が確立できなくなります。
 弊社からのエラーコードも返されません。
 お使いのシステム側で接続エラーとなります。

 貴社にてご利用いただいているAPIにおいて、
 2018年9月末(予定)までに「TLS1.2」の通信の対応が
 完了していない場合は、対応をお願いいたします。


■ お問い合わせ先
ショッピングAPIのお問い合わせ

※コマースパートナーとのご契約にてAPIサービスをご利用の場合は
 契約中のコマースパートナーへお問合せください。


今後ともYahoo!デベロッパーネットワークを宜しくお願いいたします。

同じカテゴリの記事一覧